Ir para conteúdo
  • SHOUTBOX GAMER'S BOARD ❤️

    Carregar mais
    Você não tem permissão para conversar :(
Entre para seguir isso  
FalquinhoGames

Multicraft - Erro ao iniciar o servidor

Posts Recomendados

Boa noite pessoal, tudo bem com vcs?

Bom... Sou iniciante no linux, principalmente na área de servidores, estou fazendo alguns testes instalando o multicraft (somente por diversão). Pois então, fiz a instalação do multicraft em uma distro linux (CentOS 9) em uma maquina da Azure. A instalação ocorreu sem problemas, configurei o painel e tudo mais, mas ao iniciar o Servidor de Minecraft ocorreu esse erro:

 

31.03 01:39:27 [Server] Server thread/WARN **** FAILED TO BIND TO PORT!
31.03 01:39:27 [Server] Server thread/WARN The exception was: io.netty.channel.unix.Errors$NativeIoException: bind(..) failed: Cannot assign requested address
31.03 01:39:27 [Server] Server thread/WARN Perhaps a server is already running on that port?

 

Fiz várias pesquisas na internet onde falam para realizar a liberação no firewall do linux, fiz esse procedimento, no painel da Azure liberei as portas 25565 tanto TCP quanto UDP, para qualquer tipo de entrada e saida (pode não ser da maneira certa, mas estou fazendo só por diversão como eu falei). Verifiquei quais portas os aplicativos instalados estão utilizando, e são esses:

 

COMMAND    PID      USER   FD   TYPE DEVICE SIZE/OFF NODE 
dhclient   434      root    6u  IPv4  13656      0t0  UDP 
mysqld     603     mysql   17u  IPv4  15249      0t0  TCP 
mysqld     603     mysql   41u  IPv4  85242      0t0  TCP 
sshd       607      root    3u  IPv4  14219      0t0  TCP 
sshd       607      root    4u  IPv6  14221      0t0  TCP 
apache2    614      root    4u  IPv6  14235      0t0  TCP 
apache2    619  www-data    4u  IPv6  14235      0t0  TCP 
apache2    621  www-data    4u  IPv6  14235      0t0  TCP 
apache2    622  www-data    4u  IPv6  14235      0t0  TCP 
apache2    623  www-data    4u  IPv6  14235      0t0  TCP 
apache2    624  www-data    4u  IPv6  14235      0t0  TCP 
apache2   1423  www-data    4u  IPv6  14235      0t0  TCP 
apache2   1423  www-data   11u  IPv6  98202      0t0  TCP 
apache2   4750  www-data    4u  IPv6  14235      0t0  TCP 
apache2   4752  www-data    4u  IPv6  14235      0t0  TCP 
apache2   4753  www-data    4u  IPv6  14235      0t0  TCP 
multicraf 4793 minecraft    5u  IPv4  85232      0t0  TCP 
multicraf 4793 minecraft    7u  IPv4  85240      0t0  TCP 
multicraf 4793 minecraft   12u  IPv4  84990      0t0  TCP 
sshd      5651      root    3u  IPv4 108391      0t0  TCP 
sshd      5660    filipe    3u  IPv4 108391      0t0  TCP 

 

Agora eu já não sei mais o que fazer para conseguir iniciar o servidor, só informando que para iniciar o servidor estou utilizando o Spigot padrão do multicraft.

Desde já agradeço pelo ajuda 🙂

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não sei vai ajudar.

Para abrir uma porta específica

sudo ufw allow [porta/protocolo]

Exemplos:
sudo ufw allow 56/tcp
sudo ufw deny 56/tcp

Para abrir mais de uma porta de uma vez

Exemplos:
sudo ufw allow 300:310/tcp

Abre da porta 300 a 310.

 

Se te ajudei, deixa um like ai 😄 

Compartilhar este post


Link para o post
Compartilhar em outros sites
27 minutos atrás, Ajuded disse:

Não sei vai ajudar.

Para abrir uma porta específica

sudo ufw allow [porta/protocolo]

Exemplos:
sudo ufw allow 56/tcp
sudo ufw deny 56/tcp

Para abrir mais de uma porta de uma vez

Exemplos:
sudo ufw allow 300:310/tcp

Abre da porta 300 a 310.

 

Se te ajudei, deixa um like ai 😄 

Realizei a liberação das portas como vc me disse e infelizmente o problema continua 😞

Mas muito obrigado pela ajuda 😉

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bem, aparentemente o erro se deve a ele não conseguir encontrar o IP da maquinas, normalmente essas maquinas tem proteção de IP, tenta ver qual é o IP interno do adaptador, tem um comando para isso, ou então deixa em branco, ele irá registrar a porta em todos os IPs disponíveis na maquina, porém caso seja bungee, seu servidor pode sofrer ataques diretos, sem a utilização de um plugin de proteção.

 

Edit: Tenta ver no painel, muitas vezes esses provedores tem lá para poder está habilitando a conexão cm IP.

Editado por DaltonLins

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 horas atrás, DeltaT disse:

Bem, aparentemente o erro se deve a ele não conseguir encontrar o IP da maquinas, normalmente essas maquinas tem proteção de IP, tenta ver qual é o IP interno do adaptador, tem um comando para isso, ou então deixa em branco, ele irá registrar a porta em todos os IPs disponíveis na maquina, porém caso seja bungee, seu servidor pode sofrer ataques diretos, sem a utilização de um plugin de proteção.

 

Edit: Tenta ver no painel, muitas vezes esses provedores tem lá para poder está habilitando a conexão cm IP.

Caraca mano, realmente esse era o problema, no painel do multicraft eu estava colocando o ip publico, quando coloquei o ip interno do Servidor ele funcionou.

Vlw manooo muito obrigado 😄

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
Entre para seguir isso  

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.

×
Hospedagem de Minecraft Host de Minecraft Host de Minecraft BR Host de Minecraft EUA Servidor Cloud Servidor Cloud BR Servidor Cloud EUA